CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Jun 21, 2017 - 03:16 UTC
Monitoring
A fix has been applied.. Please restart your client to play. It will take some time for all servers to receive the update.
Posted Jun 21, 2017 - 02:42 UTC
Investigating
We are currently looking into an issue that users are not able to connect to updated servers.
Posted Jun 21, 2017 - 01:19 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. Our game servers are currently being updated automatically.
Posted Jun 21, 2017 - 00:51 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted Jun 21, 2017 - 00:46 UTC