CS:GO Servers
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Aug 19, 2017 - 05:56 UTC
Monitoring
We will continue to monitor the servers overnight.
Posted Aug 19, 2017 - 05:09 UTC
Identified
We have identified the cause and are working on deploying a fix currently.
Posted Aug 18, 2017 - 23:30 UTC
Investigating
We are currently investigating users experiencing lag spikes on the CS:GO servers.
Posted Aug 18, 2017 - 22:18 UTC