CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Apr 13, 2017 - 02:47 UTC
Monitoring
We have released an ESEA Client update. Please update your client and restart your game to receive the update. Our game servers are currently being updated automatically.
Posted Apr 13, 2017 - 01:00 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted Apr 13, 2017 - 00:29 UTC