Payment Processor Outage
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 08, 2018 - 22:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Dec 08, 2018 - 21:43 UTC
Investigating
Our payment processor Xsolla is currently experiencing an outage. You may experience trouble processing payments through Xsolla during this time.
Posted 6 months ago. Dec 08, 2018 - 21:09 UTC
This incident affected: Payment Processing (Xsolla).