Improper Server Locations
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Dec 14, 2017 - 04:08 UTC
Monitoring
We have released an update to resolve the issue. Please restart your ESEA Client to ensure you are connected to the proper region. We will continue to closely monitor this fix.
Posted Dec 14, 2017 - 02:46 UTC
Investigating
We are aware that some users are being matched (ie: EU players in NA matches) into an improper region or told that there are not any locations available. Updates to follow.
Posted Dec 14, 2017 - 02:17 UTC