CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Apr 26, 2017 - 04:58 UTC
Monitoring
We are in the process of updating the servers with a new update that should fix the issues from the latest CS:GO patch. We are monitoring the servers for any bugs that may appear. It will take some time for all servers to receive the update.
Posted Apr 26, 2017 - 03:59 UTC
Investigating
We are investigating an issue related to the update that effects all community servers. More details will be posted as available.
Posted Apr 26, 2017 - 01:33 UTC
Monitoring
We have released an ESEA Client update. Please update your client and restart your game to receive the update (a progress bar may not show). Our game servers are currently being updated automatically.
Posted Apr 26, 2017 - 00:41 UTC