Steam/CSGO Down
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Apr 20, 2023 - 20:26 UTC
Monitoring
The Steam/CSGO network appears to be coming back online. We will continue to monitor.
Posted Apr 20, 2023 - 19:56 UTC
Investigating
We are aware of the issues with the Steam and CSGO network and we advise teams involved in tonight's ESEA League games to consider rescheduling to a later date/time, using the match comments, as the issue appears to persist.
Posted Apr 20, 2023 - 19:26 UTC
This incident affected: Game Servers.