CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Jul 19, 2018 - 04:23 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. There was no required game server update.
Posted Jul 19, 2018 - 04:13 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted Jul 19, 2018 - 04:07 UTC
This incident affected: Client and Match Making.