Clips Delays
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Feb 23, 2022 - 01:07 UTC
Monitoring
A fix has been implemented.
The backlog is being processed, we are monitoring the results.
Posted Feb 23, 2022 - 00:24 UTC
Investigating
The Clip system is currently experiencing delays.

You can still request clips as normal.
Posted Feb 22, 2022 - 21:02 UTC
This incident affected: Clips.