CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 20, 2019 - 04:13 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 2 months ago. Mar 20, 2019 - 00:30 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 2 months ago. Mar 20, 2019 - 00:18 UTC
This incident affected: Client and Match Making.