CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 17 days ago. Aug 03, 2018 - 03:44 UTC
Update
We are continuing to investigate this issue.
Posted 17 days ago. Aug 03, 2018 - 03:44 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 17 days ago. Aug 03, 2018 - 00:23 UTC
This incident affected: Client and Match Making.