Server Outage (Istanbul)
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 19, 2019 - 16:01 UTC
Investigating
We are currently experiencing an outage in our Istanbul location. Expect connectivity trouble in this location while we mitigate this outage.
Posted 4 months ago. Mar 18, 2019 - 22:32 UTC
This incident affected: Game Servers (Europe) (Istanbul).