CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 15 days ago. Oct 08, 2019 - 04:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 15 days ago. Oct 08, 2019 - 03:55 UTC
Update
We continue to work toward a resolution from tonight's update. Other server operators report similar issues and downtime. Updates to follow.
Posted 15 days ago. Oct 08, 2019 - 03:16 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 15 days ago. Oct 08, 2019 - 01:09 UTC
This incident affected: Client and Match Making.