CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Dec 05, 2017 - 23:46 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. It does not appear that servers required an update. Frag on!
Posted Dec 05, 2017 - 23:35 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted Dec 05, 2017 - 23:28 UTC