CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 07, 2018 - 02:28 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 4 months ago. Aug 07, 2018 - 02:25 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 4 months ago. Aug 07, 2018 - 01:30 UTC
This incident affected: Client and Match Making.