CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Mar 03, 2020 - 23:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2020 - 22:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 03, 2020 - 22:28 UTC
Update
We are continuing to investigate an update to support today's CSGO game server update.
Posted Mar 03, 2020 - 22:01 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted Mar 03, 2020 - 21:32 UTC
This incident affected: Client and Match Making.