CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 5 months ago. Nov 15, 2018 - 03:15 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. Servers are still automatically updating.
Posted 5 months ago. Nov 15, 2018 - 02:42 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 5 months ago. Nov 15, 2018 - 02:20 UTC
This incident affected: Client and Match Making.