Website Maintenance
Incident Report for ESEA
Resolved
The maintenance has been completed.
Posted 3 months ago. Feb 21, 2019 - 02:22 UTC
Identified
We are currently performing website maintenance. You may experience a brief outage to our website while we perform this maintenance.
Posted 3 months ago. Feb 20, 2019 - 22:00 UTC
This incident affected: Web (fragshack.esea.net, play.esea.net).