Increased Error Rate For Xsolla Payments
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Jul 16, 2018 - 06:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2018 - 06:04 UTC
Identified
The issue has been identified, Xsolla are implementing a fix.
Posted Jul 16, 2018 - 06:02 UTC
Investigating
We are currently investigating a potential outage with our payment processor. Users may experience issues starting new subscriptions and/or purchasing points.

Existing subscriptions are unaffected.
Posted Jul 16, 2018 - 05:57 UTC
This incident affected: Payment Processing (Xsolla).