CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 2 months ago. Dec 14, 2018 - 01:05 UTC
Update
We are continuing to monitor for any further issues.
Posted 2 months ago. Dec 13, 2018 - 23:48 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. Servers are still automatically updating.
Posted 2 months ago. Dec 13, 2018 - 23:45 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 2 months ago. Dec 13, 2018 - 23:39 UTC
This incident affected: Client and Match Making.