ISP Degradation (North America)
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Apr 22, 2020 - 14:15 UTC
Monitoring
We are tracking ongoing ISP issues in North America, impacting primarily West coast and Central users. Many residential ISPs and internet backbone providers are experiencing heavy packet loss and network degradation.

While this is beyond our control, we continue to monitor the situation as it impacts our users.
Posted Apr 21, 2020 - 16:48 UTC
This incident affected: Game Servers (North America) (Chicago, Dallas, Denver, Los Angeles, San Jose, Seattle).