CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 19, 2019 - 03:33 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 3 months ago. Feb 19, 2019 - 01:19 UTC
Investigating
There has been an update released for CSGO. We are investigating a possible update required to our client.
Posted 3 months ago. Feb 19, 2019 - 01:15 UTC
This incident affected: Client and Match Making.