CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Apr 12, 2022 - 21:54 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted Apr 12, 2022 - 21:39 UTC
This incident affected: Client and Match Making.