CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Aug 16, 2018 - 01:51 UTC
Monitoring
Our team has released and update and you are free to queue! Good luck out there!
Posted Aug 16, 2018 - 01:51 UTC
Update
Our team is continuing to work on updating all servers. An update will be posted here once the update has been completed.
Posted Aug 16, 2018 - 01:02 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted Aug 15, 2018 - 23:45 UTC
This incident affected: Client and Match Making.