CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 27 days ago. Sep 26, 2019 - 00:25 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 27 days ago. Sep 25, 2019 - 23:00 UTC
This incident affected: Client and Match Making.