CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 17 days ago. Aug 08, 2019 - 21:43 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 17 days ago. Aug 08, 2019 - 20:43 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 17 days ago. Aug 08, 2019 - 20:29 UTC
This incident affected: Client and Match Making.