CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 25, 2019 - 06:32 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. Servers are still automatically updating.
Posted 9 months ago. Jan 25, 2019 - 00:38 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 9 months ago. Jan 25, 2019 - 00:36 UTC
This incident affected: Client and Match Making.