Denver Outage
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 13 days ago. Aug 12, 2019 - 18:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 13 days ago. Aug 12, 2019 - 18:29 UTC
Investigating
We are currently experiencing an outage in our Denver location. Expect connectivity trouble in this location while we mitigate this outage.
Posted 13 days ago. Aug 12, 2019 - 17:53 UTC
This incident affected: Game Servers (North America) (Denver).