CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 24 days ago. Jul 27, 2018 - 01:52 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. No server update is required.
Posted 24 days ago. Jul 27, 2018 - 01:52 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 24 days ago. Jul 27, 2018 - 01:24 UTC
This incident affected: Client and Match Making.