TF2 Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted May 14, 2019 - 18:38 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted May 14, 2019 - 17:24 UTC
Investigating
There has been an update released for TF2. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted May 14, 2019 - 17:21 UTC
This incident affected: Client and Match Making.