CSGO Update Released
Incident Report for ESEA
Resolved
We have released an ESEA Client update. Please restart your game to receive the update. Our game servers are currently being updated automatically.
Posted 13 days ago. Oct 09, 2019 - 23:57 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 13 days ago. Oct 09, 2019 - 23:52 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 13 days ago. Oct 09, 2019 - 23:36 UTC
This incident affected: Client and Match Making.