CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 23 days ago. May 01, 2019 - 03:55 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 23 days ago. May 01, 2019 - 00:35 UTC
This incident affected: Client and Match Making.