Residential ISP Outages
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted Oct 18, 2019 - 19:31 UTC
Monitoring
There are several major residential ISPs that are experiencing routing trouble and outages, unrelated to the ESEA Platform. Players using these impacted ISPs may experience trouble connecting to games until these issues are resolved.

We continue to monitor the situation.
Posted Oct 18, 2019 - 16:28 UTC
This incident affected: Match Making.