CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 18, 2019 - 22:13 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted about 1 month ago. Jul 18, 2019 - 22:05 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted about 1 month ago. Jul 18, 2019 - 22:03 UTC
This incident affected: Client and Match Making.