CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 19, 2019 - 00:20 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 3 months ago. Jun 18, 2019 - 23:49 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 3 months ago. Jun 18, 2019 - 23:23 UTC
This incident affected: Client and Match Making.