CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 07, 2018 - 17:50 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. There was no server update.
Posted 3 months ago. Jul 07, 2018 - 17:50 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 3 months ago. Jul 07, 2018 - 17:41 UTC
This incident affected: Client and Match Making.