CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 4 days ago. Jun 11, 2019 - 22:46 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 4 days ago. Jun 11, 2019 - 22:15 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 4 days ago. Jun 11, 2019 - 21:58 UTC
This incident affected: Client and Match Making.