CSGO Update Released
Incident Report for ESEA
Resolved
No server update is required. Please restart your game to receive the update that was released.
Posted 3 months ago. Feb 16, 2019 - 01:25 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. We are investigating if there is a server update required.
Posted 3 months ago. Feb 16, 2019 - 01:03 UTC
This incident affected: Client and Match Making.