CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 14, 2019 - 03:38 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. There was no server update required.
Posted 4 months ago. Feb 14, 2019 - 02:57 UTC
This incident affected: Client and Match Making.