CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 3 months ago. May 07, 2019 - 04:14 UTC
Monitoring
No ESEA Client update is required. Game servers continue to update automatically.
Posted 3 months ago. May 07, 2019 - 02:59 UTC
Investigating
There has been an update released for CSGO. If required, our game servers will be updated automatically. We are investigating a possible update required to our client.
Posted 3 months ago. May 07, 2019 - 02:30 UTC
This incident affected: Client and Match Making.