CSGO Update Released
Incident Report for ESEA
Resolved
Updates have been released. Matchmaking has been re-enabled. At this time, we do not support the new Panorama UI, but are actively investigating supporting it.
Posted 16 days ago. Jul 07, 2018 - 00:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 16 days ago. Jul 06, 2018 - 23:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 16 days ago. Jul 06, 2018 - 23:14 UTC
Update
We are continuing to investigate this issue.
Posted 17 days ago. Jul 06, 2018 - 22:29 UTC
Update
Our team has identified a required update and is working towards updating the ESEA Client and servers.
Posted 17 days ago. Jul 06, 2018 - 22:01 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 17 days ago. Jul 06, 2018 - 21:31 UTC
This incident affected: Client and Match Making.