Clips
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 17 days ago. Aug 29, 2019 - 15:52 UTC
Investigating
Clips is currently experiencing an outage. and we are working on implementing a fix. You can still request clips, and they will be queued for completion once the system is operational again.
Posted 18 days ago. Aug 29, 2019 - 04:41 UTC
This incident affected: Clips.