CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 10 months ago. Dec 14, 2018 - 20:00 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 10 months ago. Dec 14, 2018 - 19:23 UTC
This incident affected: Client and Match Making.