Steam Outage
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 11 days ago. Mar 08, 2019 - 02:10 UTC
Monitoring
Steam and CS:GO services appear to be recovering. We continue to monitor the situation.
Posted 11 days ago. Mar 08, 2019 - 00:52 UTC
Identified
Steam is currently down. As such, users will be unable to play CS:GO and TF2 on ESEA until Steam is back online. We will continue to monitor the situation.
Posted 11 days ago. Mar 07, 2019 - 22:17 UTC
This incident affected: Match Making.