Private Messaging Delay
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 29, 2018 - 20:04 UTC
Identified
We are aware of a delay in private messaging on the play.esea.net website. In some instances, users may receive a duplicate message. A fix is being implemented to resolve this.
Posted 3 months ago. Dec 29, 2018 - 19:12 UTC
This incident affected: Web (play.esea.net).