CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 5 days ago. Dec 07, 2018 - 02:52 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update. Servers are still automatically updating.
Posted 5 days ago. Dec 07, 2018 - 02:14 UTC
Identified
We are working hard on updating our game servers and ESEA Client to work with tonight's CSGO update. Updates to follow.
Posted 5 days ago. Dec 06, 2018 - 22:26 UTC
Investigating
There has been an update released for CSGO. Our game servers are currently being updated automatically. We are investigating a possible update required to our client.
Posted 5 days ago. Dec 06, 2018 - 21:21 UTC
This incident affected: Client and Match Making.