CSGO Update Released
Incident Report for ESEA
Resolved
This incident has been resolved.
Posted 28 days ago. Feb 18, 2019 - 23:43 UTC
Monitoring
We have released an ESEA Client update. Please restart your game to receive the update.
Posted 28 days ago. Feb 18, 2019 - 23:36 UTC
Investigating
There has been an update released for CSGO. We are investigating a possible update required to our client.
Posted 28 days ago. Feb 18, 2019 - 23:30 UTC
This incident affected: Client and Match Making.